Skip to main content

Help

Accessibility

We strive to make this site accessible to all people requesting our services.

Please check your browser version and security settings as follows:

We support the following desktop browsers. If you are not using one of these browsers (or versions) to interact with our website, please download or upgrade to a new browser or supported version from any of the sites below. If you elect not to upgrade your desktop browser, your experience may not be optimal, or you may not be able to use certain tools on our website.

To provide our customers the most effective and secure online access to their accounts, we are continually upgrading our online services. As we add new features and enhancements to our service, older browser versions or Internet devices may not support these new standards. Upgrading to a new version will enhance your security and experience on our website.

Please note: In certain circumstances, we may need to block certain browsers and software from accessing "My Account Online Access" due to possible security risks and may not be able to inform you in advance.

Desktop Browser Windows XP or Vista Windows 7,8,10 Mac OS X Download Link
Microsoft Internet Explorer * Not Supported Version 11 or higher Not Supported Microsoft Internet Explorer 11
Google Chrome Version 30 or higher Version 30 or higher Version 30 or higher Google Chrome
Mozilla Firefox Version 27 or higher Version 27 or higher Version 27 or higher Mozilla Firefox
Opera Version 17 or higher Version 17 or higher Version 17 or higher Opera
Apple Safari Not Supported Not Supported Version 7 or higher Apple Safari

*Please note that Microsoft ended all support and updates for Windows XP and IE8 in April 2014.

If you are using Internet Explorer 11 and are experiencing issues, please check your Security Settings:

  1. Click on the Tools gear icon in the upper right of the browser or press Alt-x
  2. Click on Internet Options
  3. Click on the Advanced tab
  4. Scroll down to the bottom
  5. Make sure the following are unchecked:
    • Use SSL 2.0
    • Use SSL 3.0
  6. Check the following:
    • Use TLS 1.0
    • Use TLS 1.1
    • Use TLS 1.2